Jump to content
TorGuard
  • 0
Yoshiki

Help with port forwarding with an Airport Extreme, to Vuze via Mac...

Rate this question

Question

Yoshiki

Hi!

 

Maybe I'm getting rusty (probably ;p heh~)... but I please need some help with setting up port forwarding to Vuze, using a new Airport Extreme via a Mac (VPN/socks).  For whatever reason, Vuze says that the routing is good, NAT is good but the connection is firewalled (could it be my ISP???).  So here's my setup:...

 

Mac:

Connecting to VPN using L2PT in the Network control pane.  PPP is setup to a manual-static, local IP address (was automatic before - behind NAT - both work).  Proxies configured (with authentication):

Web:  port 6060

Secure web:  993

FTP:  443???

Socks: 1085

 

Vuze:

Incoming TCP listen port:  6881

Incoming UDP listen port:  6881

Socks proxy port:  1085

HTTP seeding port:  6060

 

Airport Extreme:

Network - Port settings:

Public UDP ports:  6881

Public TCP ports:  6881

Private IP address:  to manual-static, local IP address on Mac

Private UDP ports:  6881

Private TCP ports:  6881
 
So... what am I doing wrong here xD ;p ???... something has to be off ;o .  I used to be able to work this out a-ok ages ago on Transmission, but times have changed and have become more complex ;p .  Also, I apologize if this question falls under what may be the wrong forum topic, but this could fall under several ;o ... so this one seems like the best of all ;p heh...
 
Anyways, thank you so much in advance for any of your help - anywhere - anytime ^^ !!!~  :)
 
^_^

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
TorGuard

Hi!

 

Maybe I'm getting rusty (probably ;p heh~)... but I please need some help with setting up port forwarding to Vuze, using a new Airport Extreme via a Mac (VPN/socks).  For whatever reason, Vuze says that the routing is good, NAT is good but the connection is firewalled (could it be my ISP???).  So here's my setup:...

 

Mac:

Connecting to VPN using L2PT in the Network control pane.  PPP is setup to a manual-static, local IP address (was automatic before - behind NAT - both work).  Proxies configured (with authentication):

Web:  port 6060

Secure web:  993

FTP:  443???

Socks: 1085

 

Vuze:

Incoming TCP listen port:  6881

Incoming UDP listen port:  6881

Socks proxy port:  1085

HTTP seeding port:  6060

 

Airport Extreme:

Network - Port settings:

Public UDP ports:  6881

Public TCP ports:  6881

Private IP address:  to manual-static, local IP address on Mac

Private UDP ports:  6881

Private TCP ports:  6881

 

So... what am I doing wrong here xD ;p ???... something has to be off ;o .  I used to be able to work this out a-ok ages ago on Transmission, but times have changed and have become more complex ;p .  Also, I apologize if this question falls under what may be the wrong forum topic, but this could fall under several ;o ... so this one seems like the best of all ;p heh...

 

Anyways, thank you so much in advance for any of your help - anywhere - anytime ^^ !!!~   :)

 

^_^

 

 

Hello Yoshiki, welcome to the forums!

 

My first guess would be that you forgot to add the port(s) to your operating system firewall, Vuze has made a guide to how to do that here: https://wiki.vuze.com/w/Firewalling#Mac_OS_X

 

Next, ISP's can restrict L2TP and PPTP. I would recommend you setup an SSH Tunnel to bypass ISP restrictive filtering if that may be the case. There doesn't seem to be any guides for how to setup SSH tunnel for macOS. However you can create an SSH tunnel via terminal with: ssh -D 1080 -f -C -q -N [email protected] -p 22 —  Thanks to XxUnkn0wnxX, then set up Vuze to use ip address 127.0.0.1 and port 1080(or port 443) on SOCKS5. I don't use macOS, but that command should work. SSH IP and Tunneling can be enabled from the dashboard here: https://torguard.net/tgconf.php?action=vpn-ssh

 

If you only have the Proxy plan with TorGuard, I recommend you to get the VPN plan too, as it has stealth capabilities for when an ISP blocks/filters traffic and ports. Plus OpenVPN offers better security and anonymity than L2TP/PPTP.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×