Jump to content
TorGuard
  • 0

ASUS Merlin 380.65 vpn issue

Rate this question


DFK61
 Share

Question

Hello all.

 

I upgraded from 380.61 to 380.65.  Has anybody gotten the VPN to work with the new version?  I applied all of the regular settings but i need a few new options.  I looked in the logs and saw the following below.

 

Feb 10 15:03:42 rc_service: httpds 1724:notify_rc start_vpnclient1
Feb 10 15:03:42 openvpn[1961]: Options error: Unrecognized option or missing or extra parameter(s) in config.ovpn:32: push (2.4.0)
Feb 10 15:03:42 openvpn[1961]: Use --help for more information.
Feb 10 15:03:42 syslog: VPN_LOG_ERROR: 522: Starting OpenVPN failed...

 

New Drop down menu options in 380.65

 

Cipher Negotiation - Enable (With Fallback) , disable, enable

Negotiable ciphers -  AES-128-GCM:AES-256-GCM:AES-128-CBC:AES-256-CBC

Legacy/fallback cipher - (List of different ciphers)

Compression - Disabled, None, LZO, LZO Adaptive, LZ4

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Hello all.

 

I upgraded from 380.61 to 380.65.  Has anybody gotten the VPN to work with the new version?  I applied all of the regular settings but i need a few new options.  I looked in the logs and saw the following below.

 

Feb 10 15:03:42 rc_service: httpds 1724:notify_rc start_vpnclient1

Feb 10 15:03:42 openvpn[1961]: Options error: Unrecognized option or missing or extra parameter(s) in config.ovpn:32: push (2.4.0)

Feb 10 15:03:42 openvpn[1961]: Use --help for more information.

Feb 10 15:03:42 syslog: VPN_LOG_ERROR: 522: Starting OpenVPN failed...

 

New Drop down menu options in 380.65

 

Cipher Negotiation - Enable (With Fallback) , disable, enable

Negotiable ciphers -  AES-128-GCM:AES-256-GCM:AES-128-CBC:AES-256-CBC

Legacy/fallback cipher - (List of different ciphers)

Compression - Disabled, None, LZO, LZO Adaptive, LZ4

 

Hey there, the latest build uses openvpn 2.4 - if you have config lines set under the custom configuration box i would suggest remove them and retest.

 

Regards

Link to comment
Share on other sites

  • 0

Hey there, the latest build uses openvpn 2.4 - if you have config lines set under the custom configuration box i would suggest remove them and retest.

 

Regards

 

Thanks.  I removed the config files that were imported from the .ovpn file. Then turn it back on and it worked. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...