Jump to content
TorGuard
  • 0

Autostart on Boot doesn't appear to work on most recent Win 10 client

Rate this question


Torguard VPN User 1337

Question

Torguard VPN User 1337

I've installed the latest Windows VPN client on 3 different Windows-10 installations and none of them appear to autostart on boot despite having the option checked in the General settings tab.

 

It might be because I'm installing the client on a non-admin user account despite the VPN app requested elevated admin privileges.

 

I found an old post from 2015 that suggested the following registry setting. Is it still valid?

 

 

hkey_local_machine\software\wow6432node\microsoft\windows\currentversion\run

 

"C:\Program Files (x86)\VPNetwork LLC\TorGuard\TorGuardDesktopQt.exe"

 

Thanks

Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I've installed the latest Windows VPN client on 3 different Windows-10 installations and none of them appear to autostart on boot despite having the option checked in the General settings tab.

 

It might be because I'm installing the client on a non-admin user account despite the VPN app requested elevated admin privileges.

 

I found an old post from 2015 that suggested the following registry setting. Is it still valid?

 

 

hkey_local_machine\software\wow6432node\microsoft\windows\currentversion\run

 

"C:\Program Files (x86)\VPNetwork LLC\TorGuard\TorGuardDesktopQt.exe"

 

Thanks

 

 

Hello,

 

The TG Client requires admin to boot at startup unfortunately at this moment in time.

 

Regards

Link to post
Share on other sites
  • 0
YamatoGun

Hi,

Can we now start TorGuard client without admin permissions? I think it's not possible right now 😐

Having separate a account for admin in Windows 10 is a good security practice, so I NEVER log or use Admin account for daily purposes. 

Would it be possible to have a workaround?

Thanks

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...