Jump to content
TorGuard

Search the Community

Showing results for tags 'arch'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • General Stuff
    • Member Tutorials
    • TorGuard Reviews
  • TorGuard Software Releases
    • Network Status
    • TorGuard Client Releases
    • Android Client Releases
    • iOS App Releases
    • Chrome Extension Releases
    • Firefox Extension Releases
  • TorGuard VPN Support
    • VPN Questions and General Support
    • VPN Windows Support
    • VPN Mac Support
    • VPN Linux Support
    • VPN Router Support
    • iOS VPN Support
    • Android VPN Support
  • TorGuard Proxy Support
    • Proxy Questions and General Support
    • Firefox Extension Support
    • Chrome Extension Support

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 2 results

  1. After installing Torguard on Arch Linux using the PKGBUILD from the downloads section of this site, you may find the UI doesn't open. If you try running sudo /usr/bin/torguard from the command line you might see the following message qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem. Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb. /usr/bin/torguard: line 54: 12651 Aborted $SUDO /opt/torguard/bin/torguard Thanks to a tip from the Qt forums https://forum.qt.io/topic/93247/qt-qpa-plugin-could-not-load-the-qt-platform-plugin-xcb-in-even-though-it-was-found/3 I set the QT_DEBUG_PLUGINS=1 # export QT_DEBUG_PLUGINS=1 # . /usr/bin/torguard (Note the period and space before the command to run the command in the current process and pick up the environment variable) [ -- SNIP -- ] "archreq": 0, "className": "QXcbIntegrationPlugin", "debug": false, "version": 330752 } Got keys from plugin meta data ("xcb") QFactoryLoader::QFactoryLoader() checking directory path "/opt/torguard/bin/platforms" ... Cannot load library /opt/torguard/plugins/platforms/libqxcb.so: (libxkbcommon-x11.so.0: cannot open shared object file: No such file or directory) QLibraryPrivate::loadPlugin failed on "/opt/torguard/plugins/platforms/libqxcb.so" : "Cannot load library /opt/torguard/plugins/platforms/libqxcb.so: (libxkbcommon-x11.so.0: cannot open shared object file: No such file or directory)" qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found. This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem. Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, webgl, xcb. Aborted The trace showed clearly that libxkbcommon-x11 was missing, this was easily fixed # pacman -S QT_DEBUG_PLUGINS=1 problem solved, hope this helps someone!
  2. I ran makepkg and installed the software but when I run it I get the following: ERROR: Cannot open TUN/TAP dev /dev/net/tun: No such device (errno=19) Any ideas?
×
×
  • Create New...