Jump to content
TorGuard

Search the Community

Showing results for tags 'Settings'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • The Lounge
    • General Stuff
    • Member Tutorials
    • TorGuard Reviews
  • TorGuard Software Releases
    • Network Status
    • TorGuard Client Releases
    • Android Client Releases
    • iOS App Releases
    • Chrome Extension Releases
    • Firefox Extension Releases
  • TorGuard VPN Support
    • VPN Questions and General Support
    • VPN Windows Support
    • VPN Mac Support
    • VPN Linux Support
    • VPN Router Support
    • iOS VPN Support
    • Android VPN Support
  • TorGuard Proxy Support
    • Proxy Questions and General Support
    • Firefox Extension Support
    • Chrome Extension Support

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Found 3 results

  1. Was looking to find the best balanced settings for Torguard providing the most security with only a reasonable hit to throughput but could not find much details online. I decided to run some throughput tests on a few combinations of settings to determine the best option. The tests were done using speedtest.net using the same fixed remote server for all tests. In Torguard using the pin feature, I also fixed the VPN server IP for all tests. Throughput obviously varied based on server/ISP load but not by much. Also any test combinations where the numbers seemed to not make sense, I verified by doing the test again. Fixed Variables - Software Version - v3.90.0 - Used OpenVPN. I did test with OpenConnect with not much difference in speed and from the research so far OpenVPN is a more secure reliable option as of now. - Used UDP. TCP was about 40% slower than UDP and for general PC use losing a few packets has almost no noticeable effect. - Port - 1195 (SHA 256) - All other settings excluding the configuration changes listed below in the test were at default values. - Tests were done in order of security level (low to high) starting with Torguard completely disabled. Test Results Encryption Network Settings DL (Mbps) Loss Torguard Disabled Torguard Disabled 193 0% AES-128-CBC Default 164 15% AES-128-GCM Default 166 16% AES-256-CBC Default 160 20% AES-256-GCM Default 155 24% AES-256-CBC Block Outside DNS = On Name Server = None 163 19% AES-256-GCM Block Outside DNS = On Name Server = None 176 10% AES-256-CBC Block Outside DNS = On Name Server = VPN DNS 161 18% AES-256-GCM Block Outside DNS = On Name Server = VPN DNS 175 11% AES-256-CBC Block Outside DNS = On Name Server = Google 163 17% AES-256-GCM Block Outside DNS = On Name Server = Google 163 18% AES-256-CBC Block Outside DNS = Off Name Server = VPN DNS 164 18% AES-256-GCM Block Outside DNS = Off Name Server = VPN DNS 164 18% Summary -Using AES-256 vs AES-128 showed minor drop in throughput. -Adding the extra layers of security under DNS to prevent DNS resolve leaks had no negative impact on throughput. -Surprisingly after multiple repeat tests AES GCM (more secure) seems to provide better results using some of the DNS settings. Again there are obviously alot of other variables that would have impacted some of the results so they cannot be 100% accurate. It is also a limited test only taking 2 servers in to account but it does give a decent general idea as to what the best balanced options would be. Based on this test, the last configuration (in green) is the most secure option with a low amount of loss in throughput. Hope this helps any questions or corrections let me know.
  2. The TG Vpn update of November 19, 2016 has somehow changed my Adapter Settings for my ethernet, wfi, and it's very own TAP windows adapter settings affecting no response from the DNS Server. So basically, I could not connect to the internet (by ethernet or wifi) and I figured it out by myself on how to fix the issue. I had to make sure that I had to change IPv4 and IPv6 Settings on said adapters to obtain IPv4 and IPv6 addresses and DNS Server Addresses automatically and it would fix the issue... BUT then the settings would change so I have to figure out which adapter had the settings changed, whether be it TG (TAP) adapter or my own Ethernet or wifi adapters, I have to manually fix it. Is this some kind of glitch??? or error?
  3. Hello. I've been using the Anonymous Torrent Proxy service for nine months now, and I have a suspicion that I've been making a mistake in my usage. I have Bittorrent, and my settings on it are configured. I also have the Torguard application. I always open the Torguard application before opening Bittorrent, and I've been under the impression that it's needed to have Bittorrent connect through the proxy. After mistakenly leaving the default on Bittorrent to open on start up, I accidentally had it running for some time today without having opened Torguard. Despite this, the "Check My IP" torrent was giving me the "Success" message in it's trackers. This leads me to suspect. Do configured torrent clients work through the proxy even without the Torguard application open and connected? Is my privacy secure running Bittorrent on it's own with the settings correct? Have I exposed my private information at any point? Any help on this topic would be greatly appreciated. Thank you.
×